This forum is no longer open and is for reading/searching only.

Please use our new MachForm Community Forum instead.

MachForm Community Forums » MachForm 4

Machform on Godaddy Problems


  1. gregwhite
    Member

    I'm using Machform on a client's website hosted on Godaddy.

    Almost everything is working fine. The client is receiving his copy of the form, the user is receiving his copy as a Receipt. All fine.

    The only thing that does not work is the Submission Confirmation.

    No matter what is selected, i.e., Show Text or Redirect to Website, the User sees:

    Server Error
    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    All the emails go out, the database is updated, everything is fine, except for the Submission Confirmation.

    The really funny thing is that as I was working on these four forms, I would swear that it was working at the beginning..

    My forms are fairly complicated, so I even went back and created a two line form with a Name and an Email Address, and it does the same thing.

    Machform Customer Support is looking at the problem, but no luck yet. So I thought I'd throw it out to the group.

    Thanks,
    Greg

    Posted 5 years ago #
  2. nlcmc
    Member

    I need help with this too! Having the exact same problem! Everything works fine except for the Internal Error warning at submission. Email still sends. Using godaddy as well. Was the problem with them? Did you ever get it sorted out? Somebody,... anybody... a solution pleaseeeeee

    Posted 4 years ago #
  3. mhannen
    Member

    I don't think that is an issue specific to GoDaddy. It may very well be something in MachForm. We don't use GoDaddy and we've been seeing similar issues, where the user gets an error, but the submission is in fact sent.

    Posted 4 years ago #
  4. nlcmc
    Member

    Well I hope someone from Machform addresses this soon then. I'd like to believe they probably did since the initial post was from a year ago. Hopefully its just a simple setting/code to adjust. Greg.. did you get this fixed? Forum admins... any feedback?

    Posted 4 years ago #
  5. mhannen
    Member

    I submitted a ticket to support. They are asking for error logs. Since it is an intermittent problem, can someone post some of their php error logs here in the forum?

    Posted 4 years ago #
  6. nlcmc
    Member

    I submitted my information to support so hopefully they are checking on it and we'll have some feedback soon.

    Posted 4 years ago #
  7. WayneFusco
    Member

    good luck.. I emailed them 3 times over the past 3 days and haven't heard a #%$@ word other than the auto-responder.

    Posted 4 years ago #
  8. nlcmc
    Member

    Problem solved! I sent them my login info for my host and Machform admin and they fixed it. In my case (and probably yours), the problem was a folder permission issue. Below is 3 lines from the response email they sent after fixing it :

    "What we did to fix this:

    1) Adjust the "File Upload Folder" path on your Settings page to use the full path.

    2) Change the folder permission of the above setting "

    The "File Upload Folder" path they are speaking about is in the MachForm admin panel settings (advanced options in the miscellaneous settings box). They adjusted my path to "G:\PleskVhosts\mywebsite.com\httpdocs\machform\data". Note- I use Godaddy with Windows Plesk so this may differ slightly if you use Linux or something else. Then the permission folder they changed the settings for would be the "data" folder located in your Machform folder in you hosting area. By "change" I assume they mean setting the permission to writable. And thats it. Works perfect for me. Please be aware that what I have written here is what I gathered is the fixing process based on the info from their email... so there's a chance im off.

    Just to clarify - My issue was that the form worked fine but after clicking the submit button, an "Internal Error" message would be generated. I would still receive the sent message but no page redirect or confirmation message. Anyway all fixed now...hope this helps.

    Posted 4 years ago #

RSS feed for this topic

Reply