This forum is no longer open and is for reading/searching only.

Please use our new MachForm Community Forum instead.

MachForm Community Forums » MachForm 3

SSL Issues


  1. JamesHeathcote
    Member

    Dear all

    I originally installed machform on a normal http web server, since then PCI DSS have complained our forms are not secure, we have since purchased an SSL Certificate and installed on our web server.

    We have the issue that the pages of our site are secured, marked with a padlock and confirmed in page properties, but when linking to popup forms using the code from the admin panel, the pages start encrypted on page 1 (but complain about insecure content) then when you click next, the URL goes to http, but remains secure in properties and on the subsequent pages are totally insecure.

    I had ammended the URL for our site to https in the admin centre, and updated page links in the popup HTML to https but this does not fix the issue.

    Can I uninstall and reinstall the forms with the correct URL from the start reusing my 5 forms created?

    We use captcha and I wondered if you had a secure captcha page too?

    Posted 9 years ago #
  2. yuniar

    Hi James,

    No need to do re-install.

    Just make sure to get the new form code which uses the HTTPS address. You can login to your MachForm using HTTPS to get the correct form code.

    Also, if you are using custom logo or any images within the form, make sure it point to the https url.
    If the problem persist, can you let me know the URL to the page where you embed the form please?

    I'll check it.


    MachForm Founder

    Posted 9 years ago #
  3. JamesHeathcote
    Member

    The updated code sent to me fixed the problem, a massive thank you.

    Posted 9 years ago #
  4. jpello
    Member

    Yuniar,

    I also need to make my login HTTPS - What code do I need to change?

    Please email to josh.pello@yahoo.com

    Posted 9 years ago #
  5. tmparisi
    Member

    jpello, you don't need to change any code... just go to your admin panel with https instead of http. Machform works with SSL out-of-the-box. You then need to change your hyperlinks to use https when linking to the form, instead of the normal http.

    Also, if you have changed your .htaccess file on your webserver to auto redirect to https from http, then just use the format of //www.abc.com for your links instead of http://www.abc.com or https://www.abc.com. Using just the //www. will redirect using the proper protocol you set in your .htaccess file.

    Posted 9 years ago #
  6. jpello
    Member

    strange... If I change my address to https:// instead of http:// I just get a "page cannot be found".

    I'm running the current version.. hmm

    Posted 9 years ago #
  7. tmparisi
    Member

    Have you purchased a SSL certificate from your web host?

    Posted 9 years ago #
  8. christic
    Member

    If I go to the MachForm Panel, I get the lock showing it is secure, but when I go to the form, the lock flashes up and then it is gone...

    any ideas why?

    Clarence

    Posted 8 years ago #
  9. yuniar

    Are you using custom logo or any other images within the form? Make sure they all are using "https" path as well.


    MachForm Founder

    Posted 8 years ago #
  10. AMurray
    Pro Member

    Some browsers will give you a warning about a page containing secure and insecure content, for the reason above - if you have a logo using an absolute URL http://www.mysite.com/img/logo.jpg, this could be easily overlooked and should be changed to https://www.yoursite.com/img/logo.jpg

    Posted 8 years ago #
  11. tmparisi
    Member

    Even better... let the browser (and the .htaccess) choose for you by using: //www.yoursite.com/img/logo.jpg

    That way, whatever you force in your .htaccess (or don't force) will follow suit and never cause issues.

    For example, I have my ,htaccess setup so anyone that browses to the page will automatically be shifted to a https version. Everything on my server is also addressed using https because i didn't signify it to be http or https, I used the aforementioned manner. Now, if I have specific portions of the site that uses http (not secure) or if I decide to change any portion of the site to https or whatever in the future, all data will automatically follow suit.

    Posted 8 years ago #
  12. timcov
    Member

    But how do I get the theme editor to link using https? I assumed if I logged into manage_forms using https and created a theme uploading a custom logo it would automatically link to it via https if a user subsequently goes to my form under https - but that doesn't seem to be happening.
    My users get the browser warning:

    Mixed Content: The page at 'https://mysite.net/mform/view.php?id=12345' was loaded over HTTPS, but requested an insecure image 'http://mysite.net/mform/data/themes/images/img_f2469c3c6fd5fc1f21a28c98010b6db7-my_logo.png'. This content should also be served over HTTPS.

    The same applies even if I just use one of the patterned backgrounds that are not custom but the machform ones.
    Am I missing something obvious or is the only way to change the .htaccess so users can never access via http?

    Posted 6 years ago #
  13. Steve1951
    Member

    Try going to "Settings > Miscellaneous Settings > advanced options" and change the MachForm URL from http://mysite.net/mform/ to https://mysite.net/mform/

    Posted 6 years ago #
  14. timcov
    Member

    @Steve1951 - Many Thanks. That did the trick. I'd forgotten that setting existed.

    Posted 6 years ago #
  15. kentrichardson
    Member

    Thanks. This helped me. My logo image still had http. Easy fix!

    Posted 6 years ago #
  16. peterlagendijk
    Member

    Dear sir,

    I also have a SSL issue.
    When i look it up in the Chrome browser ( inspect element / console ) i get the message :

    Mixed Content: The page at 'https://www.ontbijtservice-noorderland.nl/machform/view.php?id=10638%22%20t…=%22Bestel%20hier%20uw%20ontbijt%22%3EBestel%20hier%20uw%20ontbijt%3C/a%3E' was loaded over HTTPS, but requested an insecure image 'http://www.ontbijtservice-noorderland.nl/machform/images/form_resources/grey-mild.png'. This content should also be served over HTTPS.
    jquery.min.js:2 Mixed Content: The page at 'https://www.ontbijtservice-noorderland.nl/machform/view.php?id=10638%22%20t…=%22Bestel%20hier%20uw%20ontbijt%22%3EBestel%20hier%20uw%20ontbijt%3C/a%3E' was loaded over HTTPS, but requested an insecure image 'http://www.ontbijtservice-noorderland.nl/machform/images/form_resources/machform.png'. This content should also be served over HTTPS.

    I'm not using a custom logo or any other images within the form.
    How and where can i change that.
    I have already try Settings > Miscellaneous Settings > advanced options" and change the MachForm URL from http://mysite.net/mform/ to https://mysite.net/mform/

    Posted 6 years ago #
  17. peterlagendijk
    Member

    Thanks to the customer service the issue is solved. I used another theme. I set it back to the default theme and the SSL problem is gone.

    Posted 6 years ago #

RSS feed for this topic

Reply